
Project 1: Rectangular Waveguide (HFSS) 
  

 
 
 
 
 
 
 
 

Objective 

• Getting Started with HFSS (a tutorial) 
• Using HFSS, simulate an air-filled WR-90 waveguide shown above.  
• To obtain the Field patterns,  intrinsic Impedance and wavelength  for the first 4 modes. 

Analysis 
 

1.) Sweep from 4-20 GHz 
2.) Analysis must include first three modes (TE10, TE20, TE01) 
3.) Generate a graph for β, λ, η vs. frequency for each mode using HFSS 

 
Report 
 

1.) Format should include title, objective, analysis/discussion, results, and conclusion 
2.) Include all relevant graphs and outputs from HFSS 
3.) Explain and discuss results for each mode using relevant field expressions 
4.) Compare results for β, λ, η with those obtained using corresponding theoretical expressions 

 
Hints and Tips: 
 

1.) Use wave ports on the front and back faces of waveguide 
2.) Length of waveguide is arbitrary, make it a few wavelengths 
3.) Adapt the mesh first at 15 GHz, make delta S 0.025 at most, and use 5 passes (more may be 

needed if delta S criteria is not met) 
4.) Set up simulation for Discrete, use 8 steps or so to generate a decent graph 
5.) Perform a ‘Ports Only’ solution and use ‘Post Process, Matrix Data’ from the Executive Window 

to look at solution to determine propagation constants and wavelength 
6.) Use ‘Post Process, Fields’ from the Executive Window to look at field distributions within the 

waveguide for the different modes 

  

 

 

 

 

 

a 

b 

a = 0.9”  (2.286cm) 
b = 0.4”  (1.016cm) 
εr = 1.0 

εr 



HFSS Tutorial 

Starting Ansoft HFSS  

Click theMicrosoft Start Button ,Select Programs and Select the Ansoft>HFSS9>HFSS9                                      
or Double click the HFSS9 icon on the desktop 

\ 

Creating Projects: 

 On the File menu, click New. You specify the name of the project when you save it using the File>Save or 
File>Save As.Open a previously saved project using the File>Open command 

 



    

 

   

 

 



To set up an HFSS design, follow this general procedure. Note that after you insert a design, you do not need to 
perform the steps sequentially, but they must be completed before a solution can be generated. 

 I -  Insert an HFSS design into a project.  

      1) On the Project menu, click Insert HFSS Design 

The new design is listed in the project tree. It is named HFSSDesignn by default, where n is the order in which the 
design was added to the project. The 3D Modeler window appears to the right of the Project Manager. You can 
now create the model geometry 

                

 

 

 

 II -Selecting the Solution Type 

Before you draw the model, specify the design’s solution type.  

    1) On the HFSS menu, click Solution Type. The Solution Type dialog box appears. 

 

2) Select Driven Modal in the solution types. 

We select Driven Modal as our model is a rectangular waveguide and Driven modal is used  for calculating the 
mode-based S-parameters of passive, high-frequency structures such as microstrips, waveguides, and 
transmission lines, which are “driven” by a source  

 

 

 



III- Setting the Model’s Units of Measurement 

You can then choose to display the model’s dimensions in the new units, or rescale the model’s dimensions to the 
new units.  

To set the model’s units of measurement: 

1. On the 3D Modeler menu, click Units. The Set Model Units dialog box appears. 

  

2. Select the new units for the model from the Select units pull-down list. 

You can  select the Rescale to new units option to rescale the dimensions to the new units. Clear the  Rescale to 
new units option (the default) to convert the dimensions to the new units without changing their scale 

3.  Click OK to apply the new units to the model. 

 

IV-  Drawing a Model 

You can create 3D objects by using HFSS’s Draw commands. Objects are drawn in the 3D Modeler window.  

To draw a WR-90 Rectangular waveguide , 

      1.  On the HFSS menu, click Draw. The Draw dialog box appears.Select Box 

 

 

 

 



 

 

      2.  Dimensions of the box can be specified while drawing the box .At the lower end of the screen on the right is 
the Coordinate entry 
fields

 

    3.  Enter the Initial XYZ coordinates and then enter the length in XY&Z direction in dX,dY&dZ .                        
For e.g to draw the box with initial point to be origin and propogation along X axis. Since it is a WR-90 rectangular 
waveguide the dimensions are  a=2.286cm  , b=1.016cm.                                      

  
Once you Draw the box the  properties window opens up , you can also specify the coordinates and size of the box 
here 

.  

The properties window can also be obtained by 

 



V- Assigning Materials  

1)  Right click on the 3D Modeler Window to get the 3D Modeler menu                                                                                 
2)  On the 3D Modeler menu, click Assign Material. 

 

    3) The Select Definition window appears. By default, it lists all of the materials in Ansoft’s global material 
library as well as the project’s local material library. 

 

4.Select a material from the list. Select Air or vacuum for the whole box as our rectangular waveguide is not 
filled with any dielectric.                                                                                                                                         
5.Click OK.                                                                                                                                                              
6. The material you chose is assigned to the object. 

 

 

 

 

 

 



 

VI- Assigning Boundaries 

Boundary conditions specify the field behavior at the edges of the problem region and object interfaces.  

 

    1) Right click on the 3D Modeler Window to select faces 

 

2) Click on the faces to select the faces which are to be assigned to be a perfect conductor                                                     
3) On the HFSS menu, click Boundaries.Select Assign and choose Finite conductivity. 

 

Assign Finite conductivity to 4 faces excluding the Port 1 and Port 2 

 

 
Select Face  



  

VII- Assigning Excitations 

Excitations in HFSS are used to specify the sources of electromagnetic fields and charges, currents, or voltages on 
objects or surfaces in the design.  

Assigining excitations is a two step process  

   VII. a) Assign Ports    
           b)Assign an Intergration Lines or Terminal lines separately for each modes  
 
a) Assigning Ports 

1. Select the object face to which you want to assign the port. 
2. Click H FSS>Excitations>Assign>Wave Port. 

Wave port represents the surface through which a signal enters or exits the geometry. Hence 2 ports are required 
to be defined. HFSS assumes that each wave port you define is connected to a semi-infinitely long waveguide 
that has the same cross-section and material properties as the port. HFSS generates a solution by exciting each 
wave port individually. 

 

3. The Wave Port wizard appears. 
4. Type the port’s name in the Name text box or accept the default name, and then click Next. 

 

 

 

 



5.  To specify more than one mode to analyze at the port, type a new value in the Number of Modes box, and 
then click Update. The mode spreadsheet is updated to include the total number of modes 

 

 

b) Defining Integration Line 

 An integration line needs to be specified to define a port mode. Since we are analysing the WR-90 waveguide 
for the first 4 modes we need to specify 4 intergration lines 

1. Select New Line from the mode’s Integration Line list.                                                                                              
2.The dialog box disappears while you draw the vector 

3.  

4. Select the start point of the vector in one of the following ways                                                                                      
4.a. Click the point. Or Type the point’s coordinates in the X, Y, and Z boxes at the lower end of the screen                 

5. Select the endpoint of the vector using the mouse or the keyboard. The endpoint defines the direction and 
length of the integration line. 

6.  The Wave Port or Lumped Port dialog box reappears. 

 

 

. 

 

 

 

 

 

 



 

 VIII-  Solution Setup 

a) Adaptive solution setup    
b) Frequency sweep setup 

     Adaptive solution setup    

 1. On the HFSS menu, point to Analysis Setup, and then click Add Solution Setup  

  

  2. The Solution Setup dialog box appears. It is divided among the following tabs: 
 
      General - Includes general solution settings 
      Advanced - Includes advanced settings for initial mesh generation and adaptive analysis 
      Ports -  (if a port was defined) Includes mesh generation options for model ports 
      Defaults - Enables you to save the current settings as the defaults for future solution setups or revert      
                        the current settings to HFSS’s standard settings.   
                                                                             
   3. Click the General tab.   
        3.a For Driven solution types, do the following:    
                                                                                                                       

     1. Enter the Solution Frequency in the frequency units. 
The minimum value for adaptive Mesh Frequency is 2/3rd of the final frequency required .Although it is 
recommended to just adapt to the Final frequency. 
Since we are analyzing the first 4 modes of the WR-90 waveguide the Cut-Off Frequency of the last mode is 
16 Ghz. Hence the Final Frequency is a value, which is higher than that. For e.g. 20Ghz 
 

        2 .Enter the Maximum Number of Passes = 10 
 

 The Maximum Number of Passes value is the maximum number of mesh refinement cycles that you      
would like HFSS to perform. This value is a stopping criterion for the adaptive solution; if the maximum 
number of passes has been completed, the adaptive analysis stops. If the maximum number of passes has 
not been completed, the adaptive analysis will continue unless the convergence criteria are reached 

 
        3. Enter the Delta s =. 002 

     The delta S is the change in the magnitude of the S-parameters between two consecutive passes. 
 
 

       4.Click Ok 

Or 



 
 
 
Frequency Sweep setup 
 

             1. In the HFSS menu Select Analysis Setup and then select Add sweep                                                                           

 

      2.The Edit Sweep Dialog Box opens. 
      3.Select Discrete and enter the Start and stop Frequency. 

Since we are analyzing the first 4 modes of the WR-90 waveguide the Cut-Off Frequency of the last mode 
is 16 Ghz. Hence the Stop Frequency is a value, which is higher than that. For e.g. 20Ghz 

      4.Click OK 
 

 

  
                                               SELECT 



 

 

VIII – Running a Simulation 

To validate your model  
   1.Select HFSS menu > Validate Check 
   2.Click OK 

 

To Analyze 

  1.On the HFSS menu, click Analyze  

 

 While a simulation is running, you can monitor the solution’s progress in the Progress window. 

 

 



You can also view the following solution data at any time during or after the solution 

 Convergence data-- by clicking HFSS>Analysis Setup>Convergence. 
 Matrices computed for the S-parameters, impedances, and propagation constants by clicking 

HFSS>Analysis Setup>Profile. 
 
Once the simulation is completed HFSS Informs you in the message window. 
 

Results 

HFSS > Results > Solution Data 
 

 
 
The solution data window appears 
 

 
 
 
 
 



HFSS computes the following matrix data 
 S, Y, and Z Parameters 
 VSWR 
 Excitations: - Gamma and Zo 

 
Plotting the results  
HFSS> Results> Create Report 
Or you can also go to the project tree and right click on results and click create report. The Create report 
window dialog box appears. 

  
 

1) Select the report type you want to view from the pull down list on the top of the dialog box 
2) Select the type of plot you want to create, from the display type pull down list. 
3) Click OK 

The Traces dialog box appears 
4) In the Solution list, click the solution containing the data you want to plot.  
5) In the domain list, click a domain. For modal and terminal S- parameter reports, the domain can be 

frequency or time. In this case we want frequency domain. 
6) Click on Add Trace, click Done 

 
 

  



 
 
Analysis and Results 

 
1) Analyze the propagation constant for the first four modes. 
2) Determine the wavelength at different frequencies for the first four modes. 
3) Determine the intrinsic impedance at different frequencies for the first four modes 
4) Analyze E and H field patterns for the first four modes. 
 
 
Plot of propagation constant vs. frequency for TE10, TE20, TE01, TE and TM11 using HFSS 

 

 
 
Note that the mode propagates only when the propagation constant has is real and the operating 
frequency is greater than its cutoff frequency. As the traveling waves are functions of exp(-jβ z), has 
to be real and make exp(-jβ z) imaginary. 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
Plot of propagation constant vs. frequency for the first four modes using Theoretical values 

 
 
Similarly you can draw plots for wavelength vs. frequency and impedance vs. frequency from the data 
given in the solution data box. 
 
1. In the project tree, right-click the solution setup of interest, and then click Matrix Data on the 
shortcut menu.The Solution Data dialog box appears. The Matrix Data tab is selected. 

2. In the Simulation pull-down list, click the solution setup and solved pass - adaptive, single 
frequency solution, or frequency sweep - for which you want to view matrices. 

3. Select the type of matrix you want to view: S,Y, and Z matrices or Zo (characteristic impedance.). 
The wavelength data is displayed  when you check the gamma box. The available types depend on the 
solution type. 

4. Select the format — Magnitude/ Phase, Real/ Imaginary, dB/ Phase, Magnitude, Phase, Real, 
Imaginary, or dB — in which to display the matrix information. The available formats depend on the 
matrix type being displayed. 

 
 
 
 
 
 
 
 
 
 
 
 



 

 
 
 
The solution data window appears 

 
 
 
 
 
 
 
 



 
Impedance vs. Frequency for the first four modes 

 

 
 
      Wavelength vs. frequency for the first four modes 
 

       
 

 



 

Field Patterns for E and H fields 
 
On the project tree click on Port Field Display>wave port 1>mode1 
The TE10 mode will be displayed in the model 

 
 
Similarly click on mode2, mode3 and mode 4 
TE20  

 
 
 
 
 



 
TE01 

 
 
TE,TM11 

 
 
 
 
 
 
 
 



To view E and H field patterns 

Select the face for which you want to view the field pattern 
On the HFSS menu click on Fields>plot fields>mag E 
For H field pattern click on Fields>plot fields>mag H 
 

 
 
Create field dialog box appears: select mag E under Quantity and the model name under volume or you 
can also select all objects. 

 
 
 
 
 
 
 
 



E field pattern in [v/m] 

 
 
The colors indicate the intensity of the field decreasing from top to bottom. 
 
H Field Pattern in [v/m] 

 
 

 


